Dronelink app (Autel EVO II) exits when I try to load a mission.

KELLEY D KIMBALL

I need some help on getting Dronelink app to function. It appears to connect to the drone, but when I load a mission I created (about 15 minutes ago) simple orbit, with start & end altitude and start & end radius. As soon as I select to load this mission the dronelink app exits everytime.

0

Comments

35 comments

  • Comment author
    Jim McAndrew Dronelink Staff

    Can you share the mission plan?

    0
  • Comment author
    KELLEY D KIMBALL

    https://app.dronelink.com/kelley-d-kimball-pi1kjjd8t2Bc1fSBARZg/my-first-project/plan/ML04SJMkMqj6InzH8XRa/bfZvM0oMUnAGEKyoivx4

     

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    I was able to run this mission without any issues. What version of the app are you using?

    0
  • Comment author
    KELLEY D KIMBALL

    4.3.1 Downloaded and installed 12/27/2022

     

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Can you try reinstalling the app, or trying it on a different device to see if we can narrow it down?

    0
  • Comment author
    KELLEY D KIMBALL

    I will try to reinstall. No other device to try it on unless you have released the Autel port on Android recently. The app doesn't have any issues with multiple accounts with the same credentials dose it? Only one of my accounts is at the needed level to utilize the Autel EVO !!. 

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    The app doesn't have any issues with multiple accounts with the same credentials dose it

    No issues

    0
  • Comment author
    KELLEY D KIMBALL

    Uninstall/Reinstall did not have any affect. I have a small 4mb video that shows the exit if interested.

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Can you share it?

    0
  • Comment author
    suren munoo

    Sorry to jack the post but does Dronelink support the Evo2 V3 as yet?

    0
  • Comment author
    KELLEY D KIMBALL

    Jim, how can I share the video with you? This forum/medium does not allow me to attach a video. Another thought I had, that perhaps the app is checking for or trying to connect with a cellular service even though I had previously downloaded the mission to the phone? I do not have cellular on this device and am only using a wifi connection.

    0
  • Comment author
    Mike (Arizona Wyldwest) Dronelink Expert Dronelink Expert
    • Edited

    Hi Kelly. You can add a link from YouTube, Vimeo, Dropbox, google drive etc….

    The downloaded mission for off-line will work and should not cause the app to close down. Whether a Wi-Fi only device or Cellular none of that is needed if downloaded. 

    Also what device are you using ?

    0
  • Comment author
    KELLEY D KIMBALL

    Here is a link to the short video. https://drive.google.com/file/d/1TM_ktZaeNE8iBAKGEUzVx_LksGXCibM3/view?usp=share_link 

    I am using a a freshly reset iphone12 IOS 16.2

    0
  • Comment author
    KELLEY D KIMBALL

    Last post still shows as "Pending Approval" 

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Are you able to load any other mission plan?

    0
  • Comment author
    KELLEY D KIMBALL

    I thought maybe I was going to have a break through. I tried loading a different mission and it did load but, after about 10-15 seconds the app exited again. I also tried touching the red oval at the top right of the screen where it says EVO II | 86% and the app immediately exits.

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Does it only crash once you enter the flight dashboard? If you don’t connect a drone can you open the flight dashboard?

    0
  • Comment author
    KELLEY D KIMBALL

    Seems to be the case. The app appears to function normally as long as the drone is not connected.

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    What it ever working before or did you do a firmware update that started causing the issue (what firmware are you on)? Is this a v1, v2, etc?

    0
  • Comment author
    KELLEY D KIMBALL
    • Edited

    I have never successfully flown my Autel EVO II Pro V2 using Dronelink Beta or Released version. Here are the firmware details.

    0
  • Comment author
    KELLEY D KIMBALL

    Well I've made some progress but success is still not obtained.

    I updated the drone's firmware to the current release version. And while this may seem like a trivial & logical step to perform, I have had serious issues with Autel Firmware updates in the past, and it has been put into a "Last Resort" category for me personally.

    After the firmware update, I can open Dronelink, load a mission, start a mission, but that's where the show ends.

    When I access the screen where I should be able to set my home point according to your support page

     

     

    The app does not display this option for me as shown in the next two images.

    The app allowed me to start the mission and the Drone launched ascended about 6 ft or so. Thinking that the obstacle avoidance may have been preventing the mission from proceeding, I paused the mission and manually flew the drone up to about 30' where there were no obstacles and hit resume. The drone just hovers, but the mission says its running. the app said it had completed but it never moved.

    Here's a link to a short video. Apologize for the crappy video but there were a few things going on.

      https://drive.google.com/file/d/1m0dKsnGgCUb5CJpIXv62vqpamhoW8HcN/view?usp=share_link

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    I updated the drone's firmware to the current release version.

    Unfortunately the Autel SDK requires the latest version of the firmware.

    set my home point according to your support page

    Which page are you referring to? Setting the home point is definitely not supported through the UI.

    The drone just hovers, but the mission says its running. the app said it had completed but it never moved.

    You need to check your settings in the Autel Explorer app as mentioned here:

    https://support.dronelink.com/hc/en-us/articles/8293359753491-Autel-EVO-II-Series-Support-Overview-and-Limitations

     

    0
  • Comment author
    KELLEY D KIMBALL
    • Edited

    Unfortunately the Autel SDK requires the latest version of the firmware. 

    Would have been nice to know this a couple weeks ago! Probably something that should be included in the Autel-EVO-II-Series-Support-Overview-and-Limitations

    set my home point according to your support page

    Which page are you referring to? Setting the home point is definitely not supported through the UI.

    The page link below does not mention any drone model specifics so, when you encounter a big red oval on the app screen that provides no indication on what to do to correct what I only assume will cause problems, what is one expected to do to correct the situation? What I did was search your support web page.

    https://support.dronelink.com/hc/en-us/articles/10149357389459-Flight-Dashboard-Menu-Drone-Settings-Max-Altitude-RTH-Altitude-Compass-Calibration-Remote-Controller

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Would have been nice to know this a couple weeks ago!

    Sorry, I guess I just assumed you had already tried that.

    what is one expected to do to correct the situation?

    The support article is a little misleading. Most of the settings show on that screen can be set but the home point one is just a read out. We plan to eventually allow updating it, but we had to draw the line somewhere on the features to get the modern dashboard released. Side note, like DJI, if Autel has a GPS signal it will automatically set the home point when the props arm.

    0
  • Comment author
    KELLEY D KIMBALL

    Next Step in this saga. All requirements/caveats set and verified. First started drone with Autel Explorer to verify home point was set. Exited the Explorer app and started Dronelink. No Big Red Oval saying Home Location not set. Selected the same saved mission Autel Orbit Plan hit the execute icon and nothing happens other than the app changes text on the screen that the mission is running. https://drive.google.com/file/d/1VsOu1-d2mjbdAOR41Uyn1F0M8sfaMTFN/view?usp=share_link 

    I then exited the mission and decided to try an On The Fly - Orbit, went through and made the required selections and clicked to start the mission & same result. It says it's running the mission but the drone does not move. https://drive.google.com/file/d/1oEH3f2IhANR7mAAI1kp1lXwHmu51aphF/view?usp=share_link 

    Are there anymore secret or non documented requirements that I'm missing? 

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Did you set all the EXP and Sensitivity settings like shown here?

    0
  • Comment author
    KELLEY D KIMBALL

    Yes I did.

    0
  • Comment author
    KELLEY D KIMBALL
    • Edited

    These issues sound very much like the issue Dronelink was having with the V1 models during the Beta. Are people actually using Dronelink with the EVO II?

    0
  • Comment author
    Jim McAndrew Dronelink Staff

    Are people actually using Dronelink with the EVO II?

    Yes, and we have multiple EVOs to test with and cannot reproduce what you are experiencing.

    0
  • Comment author
    KELLEY D KIMBALL

    As I mentioned in my last post, similar oddities were reported in this thread, any possible correlation?

    https://support.dronelink.com/hc/en-us/community/posts/8149935132563-AUTEL-EVO-II-DRONELINK-REVIVED-

    0

Please sign in to leave a comment.