Skip to main content

Mavic 2 Pro Hyperlapse using 2 seconds interval not allowed

Comments

12 comments

  • Jim McAndrew

    It's just a warning because it fails on many drones. If it works for your Mavic then great, you can ignore it.

    0
  • Antonio Jose Sinoga

    Thanks for the prompt reply, Jim. I noticed that the 2 seconds parameter is ignored when the photo file format is raw. It takes pictures every 5 seconds, even when Mapping and "Min Capture Interval" is 2 seconds.

    Is it limited by code? I mean, with something like:

    If (PhotoFileFormat = RAW) then MinCaptureInterval = 5

    It would be great to get all the best from the Mavic 2 Pro taking raw pictures every 2 seconds like when making Hyperlapses in DJI Go 4 app.

    0
  • Jim McAndrew

    It is limited by the drone's camera firmware, which is why we put the warning in.

    0
  • Antonio Jose Sinoga

    I don't want you to waste your time with this minor issue, Jim, but I really like Dronelink and I would like to make my Hyperlapses using it.

    Currently, the Hyperlapse mode can take pictures every 2 seconds in DJI Go 4 app. Litchi has an option called "Photo Capture Interval" which allow you to take pictures every 0-100 seconds or meters. I tested used 2 seconds and work properly.

    I guess these apps are using a special mode because it is true that when you use the regular parameters of the camara and set the image format to RAW, the 2 seconds interval is disabled.

     

    Thanks for your time, Jim, keep going with the great job you and Dronelink team are doing.

     

    0
  • Antonio Jose Sinoga

    Finally, I got the way to take RAW pictures every 2 seconds, even every 1 second. Dronelink is so powerful!

    0
  • Jim McAndrew

    How did you manage that?

    0
  • Antonio Jose Sinoga

    https://app.dronelink.com/antonio-jose-sinoga-de-la-torre/hyperlapses/plan/UJLwW4ScNo8U2xhgshXt/iERurDfdI3zMmRm4NaOr

    Basically, I have a list to configure my Hyperlapse settings. I think that the point has been to remove the configuration of the "Photo file format" parameter from this list. So, I set the "Photo file format" to RAW before loading the mission. It seems that when I set the photo file format to RAW in that list, the time interval was conditioned to 5 seconds, exactly the same that when you do that manually in the camara settings.

    I tested it on Android and worked properly. However, I tested on my Job's iPhone and it did not, the interval was again 5 seconds... I don't know if I was missing something in the iPhone configuration... I will do more tests tomorrow.

    I understand that the operating system should not be a difference at Dronelink app level, right?

    0
  • Jim McAndrew

    Should not matter.

    0
  • Antonio Jose Sinoga

    Jim, I found this issue on my device (iPhone 8). I don't know if it is a general Apple issue or it is only my device problem. I tried to change manually the time interval and only 5 seconds is allowed. In my Android device works as expected taking pictures every time you configure.

    However, on my iPhone 8, whenever I change the time interval, only 5 seconds is actived. I see the new time interval on the release button for a very short time, but quickly 5 seconds is again automatically actived. I tried uninstalling the app and installed it again but nothing fixed. 

    I have recorded this video where you can see what is happening.

    https://youtu.be/jb-R3QpmonE

     

     

    0
  • Jim McAndrew

    I've reproduced the issue and reported it to DJI (this is in the UX SDK code). For now you should be able to issue the time interval as a command in your mission plan to change it automatically.

    0
  • Antonio Jose Sinoga

    Thanks a lot, Jim.
    I'm not be able to issue the time interval neither as a command. That is the reason why my automatic mission works on my Android device as expected, with 2 seconds interval, but runs on my iPhone with 5 seconds interval, although the same "2 seconds" command for the interval is executed. Thanks to execute the same mission on different devices we realized what the problem is. 
    We will wait for DJI to fix the issue, in the meantime I can use my Android device if I need short time interval.

    0
  • Jim McAndrew

    Interesting. I just tried it and it worked for me.

    0

Please sign in to leave a comment.