Skip to main content

Can't Connect....what am I missing?



  • Paul McGuire

    No I apparently didn't.....newbie mistake.  Looked at app in phone setting and granted all permissions.  It is working now :-)

    Thanks....and Thanks again!!

  • Bob Hoskins

    Same here. I didn't grant the phone permisson because I didn't expect it's required for a software like dronelink. Permisson granted, problem solved.

    Jim McAndrew If the user tips the "can't connect" maybe you could show some information about possible reasons (the phone permisson one isn't obvious I think). I tried to get an idea from the screen full of "unknown status" lines, but obviously that didn't help much :)

  • Steve Regan

    I have a problem where I can't connect to the drone. I have a Pixel 5 with the latest updates (?). I found out through trial and error that I have to go into settings/apps and notifications/recently opened, and "Force Stop" the DJI Fly app before Dronelink can operate the aircraft (Mini 1) even though I quit the DJI Fly app already. 

    Any quick tips on this?


  • Jim McAndrew

    There is really no way around this, you cannot be running multiple flight apps at once. This is a DJI SDK limitation.


Please sign in to leave a comment.